Get in touch
Back
Maintenance

Platform Update

Completed 19 Oct at 08:00am CDT.

app.legalboards.io
Completed

Maintenance completed

Posted 19 Oct at 08:00am CDT.
Started

Update with new features and improvements to app.legalboards.io
The environment should not be out of breath, but it may slow down during the period.

Posted 19 Oct at 06:00am CDT.